Inkling - Inkling Web Reader Performance Degradation – Incident details

Inkling Web Reader Performance Degradation

Resolved
Operational
Started almost 6 years agoLasted about 2 hours

Affected

Inkling Web Reader

Operational from 3:25 PM to 5:15 PM

Updates
  • Update
    Update

    On January 28th, 2019, Inkling Web Reader displayed error messages for about 4 minutes starting at 7:25 AM PST. During this time, services in the Inkling platform experienced elevated error rates which the Inkling Web Reader lacked sufficient hardware capacity to handle. The engineering team was alerted and manually intervened to add hardware capacity and restore the services. Over the past two days, the team has reviewed this incident and identified several updates to improve the error handling and autoscaling mechanism of the impacted services. We have temporarily increased the hardware capacity of our platform until these improvements are complete and validated in our test environment. We are confident these steps will prevent another occurrence of this issue.

  • Resolved
    Resolved

    The incident has been resolved and Inkling Web Reader is fully operational at this time.

  • Monitoring
    Monitoring

    We have restored Inkling Web Reader and have not detected any additional issues for the past 10 minutes. We will continue to monitor the situation.

  • Investigating
    Investigating

    Inkling has received reports of Inkling Web reader performance degradation and our team is currently investigating.