Inkling Web Reader Performance Degradation

Resolved
Major outage
Started almost 2 years ago Lasted about 1 hour

Affected

Inkling Web Reader
Updates
  • Resolved
    Update

    Around 11:50 PM PT on May 23, 2022, an unexpected spike in traffic caused Inkling's database pools to prevent access to our internal identity service. This is an intentional design choice made to prevent the database itself from being overloaded. Connections queued while waiting for the prior load to clear, resulting in a subset of incoming web requests timing out. When the spike cleared, Inkling engineers restarted the underlying API to restore service. The result was approximately 35 minutes of performance degradation across Inkling services.

  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The issue is resolved and Inkling engineers are continuing to monitor this closely.