Delays in project publications

Resolved
Operational
Started 22 days ago Lasted about 1 hour

Affected

Habitat
Updates
  • Resolved
    Update

    On April 9, 2024, Inkling restarted the central API services after adding additional capacity. Following the restart, the services that process central queue items failed to connect to the queue properly. This caused items in the queue to have their processing delayed. This was mostly seen in a delay publishing Inkdocs.


    To resolve the issue, Inkling engineers reconnected the services to the queue. By 10:30 AM PT on April 10, 2024, the services processed the backlog and resumed normal service. No data was lost in this process, only delayed. Changes to the queueing system were made to ensure this does not reoccur.

  • Resolved
    Resolved

    All previously delayed project publications have been processed, and there are no longer any delays expected for new tasks.

  • Identified
    Identified

    Inkling has identified delays in project publication. We have identified the source of the problem and have remedied it. No data has been lost, and at this time Engineering is working to ensure all updates are processed. We will provide ongoing updates as we make progress.