Inkling - Inkling Web Reader Performance Degradation – Incident details

Inkling Web Reader Performance Degradation

Resolved
Major outage
Started 22 days agoLasted about 2 hours

Affected

Inkling Web Reader

Operational from 2:21 PM to 2:21 PM, Major outage from 2:21 PM to 3:55 PM

Habitat

Operational from 2:21 PM to 3:55 PM

Updates
  • Resolved
    Resolved

    Incidents Summary:

    On August 20, 2024 and August 21, 2024 Inkling encountered an issue within one of our micro-services that temporarily affected the availability of certain services, including Inkling Web Reader and Habitat. This issue was related to an unexpected data processing error identified by our monitoring tools and that caused the system to enter into an automated self correcting mode.

    Our team quickly identified that the issue originated from a specific component responsible for managing and processing data and that required an update. This disruption led to intermittent accessibility issues for users attempting to access certain features.

    Incident Timeframe:

    • Start: Tuesday, August 20th, 2024, at approximately 07:41 PT

    • End: Wednesday, August 21st, 2024 at 8:00 a.m. PT

    Resolution:

    Upon identifying the root cause, our engineering team promptly initiated corrective actions. The team implemented necessary adjustments to the affected service to ensure it could correctly handle the data it was processing. These adjustments restored normal functionality. A second incident occurred on the 21st after new strings were identified in a different section of the service. Engineering has prioritized and updated all strings to eliminate any future down time.

    Our team continuously monitored the system during this period to ensure that the fix was effective and that no further disruptions occurred. The issue was resolved within the hour, and full service was restored without any additional user impact.

    Impact:

    • Inkling Web Reader and Habitat experienced intermittent accessibility issues. During this time, some users may have encountered difficulties accessing these services.

    Next Steps:

    To prevent similar issues in the future, our engineering team is conducting a thorough review of the affected micro-service and the automated self correcting modes in the system. We are implementing additional safeguards and refining our processes to ensure no disruption in the future.

    We are committed to maintaining the reliability and performance of our services.

    We apologize for any inconvenience this incident may have caused and appreciate your understanding.

  • Investigating
    Investigating

    We are currently investigating an issue with the Inkling Web Reader performance.