Platform Service Degradation
Incident Report for Inkling
Postmortem

On Tuesday, May 28th, 2019, the Inkling platform was down for 11 minutes starting at 11:27 AM PST. A hardware failure on one of our internal load balancers caused requests to time out and prevented automatic recovery failovers from succeeding. The engineering team was alerted to the issue and simultaneously worked to restore the load balancer and restart internal services which were still impacted by the load balancer failure. After investigating the root cause and why the outage lasted longer than expected, the team has documented how to deal with this kind of outage more quickly and will be improving tooling to rapidly identify the cause of major outages.

Posted 3 months ago. May 31, 2019 - 23:13 UTC

Resolved
This incident has been resolved.
Posted 3 months ago. May 28, 2019 - 20:13 UTC
Monitoring
We have restored access to the platform and are continuing to monitor the situation.
Posted 3 months ago. May 28, 2019 - 18:43 UTC
Investigating
Inkling has received reports of a degradation in service and our team is currently investigating.
Posted 3 months ago. May 28, 2019 - 18:28 UTC
This incident affected: Inkling Web Reader.