Habitat Performance Degradation
Incident Report for Inkling
Resolved
This incident has been resolved.
Posted Aug 11, 2021 - 11:52 UTC
Investigating
Inkling has received reports of Habitat performance degradation and our team is currently investigating.
Posted Aug 11, 2021 - 10:52 UTC
This incident affected: Habitat.