Habitat Performance Degradation
Incident Report for Inkling
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 15:42 UTC
Investigating
Inkling has received reports of Habitat performance degradation and our team is currently investigating.
Posted Jan 21, 2021 - 15:22 UTC
This incident affected: Habitat.