Habitat Performance Degradation
Incident Report for Inkling
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 15:52 UTC
Investigating
Inkling has received reports of Habitat performance degradation and our team is currently investigating.
Posted Dec 08, 2021 - 07:06 UTC
This incident affected: Habitat.