Inkling Web Reader Performance Degradation
Incident Report for Inkling
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 19:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2022 - 19:30 UTC
Investigating
We are currently investigating this issue.
Posted Apr 22, 2022 - 18:58 UTC
This incident affected: Inkling Web Reader.