Habitat Performance Degradation
Incident Report for Inkling
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 16:30 UTC
Investigating
Inkling has received reports of Habitat performance degradation and our team is currently investigating.
Posted Oct 01, 2021 - 16:14 UTC
This incident affected: Habitat.