Inkling Web Reader Performance Degradation
Incident Report for Inkling
Postmortem

Around 11:50 PM PT on May 23, 2022, an unexpected spike in traffic caused Inkling's database pools to prevent access to our internal identity service. This is an intentional design choice made to prevent the database itself from being overloaded. Connections queued while waiting for the prior load to clear, resulting in a subset of incoming web requests timing out. When the spike cleared, Inkling engineers restarted the underlying API to restore service. The result was approximately 35 minutes of performance degradation across Inkling services.

Posted May 25, 2022 - 18:06 UTC

Resolved
This incident has been resolved.
Posted May 24, 2022 - 08:02 UTC
Monitoring
The issue is resolved and Inkling engineers are continuing to monitor this closely.
Posted May 24, 2022 - 06:52 UTC
This incident affected: Inkling Web Reader.